
Scripting using ImageJ Macro 

 -  a quick 1 hour tutorial -  

Kota Miura @ CMCI EMBL 

We use Fiji.  

http://fiji.sc 

… please download and install.  



2-1 Why do we write macro? 

1.  Automate Procedures 

2.  Implement your algorithm 

3.  Processing using Cluster (fast!) 

4.  Use from Cell Profiler 

5.  Limitations 

1.  Interactive processing is difficult 

2.  Re-Usability 

Aim: Students acquire ImageJ macro programming 
techniques to ease their work loads with image 
processing / analysis.  



2-2 Basics routine 

2-2-1 Hello World! (Fiji) 

[PlugIns -> Scripting -> Script Editor] 

…then set language 

[Language -> ImageJ macro]  

1. Start-up script editor 

2. And then write as follows (omit numbers) 

1: macro "print_out" { 
2:     print("Hello World!"); 
3: } 

3. Install the macro. In the 
Editor menu 

[Run -> Install Macro] 
                            (or command - I)  

Tabulate! 

5. Save the macro as  
“HelloWorld.ijm”. 

[File -> Save As…] 

4. In Fiji menu, 
[Plugins -> Macro -> Print out] 



2-2 Basics 

Second way to run script 

[Run -> Run] , or control-R (win) command-R (mac) 

By the way, you could start up script editor by ctrl-{ (win) 



2-2 Basics 

2-2-1 Hello World! 

1: macro "print_out" { 
2:     print("Hello World!"); 
3: } 

print() command 

Parameter “Hello World” 

*** { }   Braces define the boundary of macro.   

Semi-colon at the 
end of command is 
very important 



2-2 Basics 2-2-1 Hello World!:  EXERCISE 

Code 1 
1: macro "print_out" { 
2:     print("Hello World!"); 
3: } 

Exercise 2-1-1: Try modifying the print out text and 
check that the text will be printed in the "Log" window. 

Exercise 2-1-2:  
(1) Add another line “print("\\Clear");” after the second 

line (don’t forget the semi-colon at the end!).  
(2) Then test also when you insert the same command 

in the third line. What happened?   

Code 1.5 
1: macro "print_out" { 
2:  print("\\Clear"); 
3:  print("Hello World!"); 
4: } 

Code 1.75 
1: macro "print_out" { 
2:  print("Hello World!"); 
3:  print("\\Clear"); 
4: } 



2-2 Basics 

2-2-1 Hello World!:  EXERCISE 

1: macro "print_out" { 
2:     print("Hello World!"); 
3: } 

Exercise 2-1-3: Multiple macros can exist in a single 
file. We call this “macro sets”. Duplicate the code you 
wrote by copying and pasting under the original. The 
second macro should have a different name. In the 
example here, the second macro is named “pirnt_out2”. 



2-2 Basics 

Second way to run script 

[Run -> Run] (imited to the first macro) 



2-2 Basics 

Third way to run script 

First make a selection (purple) 

… then [Run -> Run Selected Code] 



2-2 Basics 

By the way,  

you could always make a new tab to 
edit another script while you still 
have the current one.  

try  
[File > New] 



2-2 Basics 

2-2-4 Including ImageJ Macro Commands into your macro 

“Macro Recorder”  a very powerful tool for macro programming 

[PlugIns -> Macros -> Record…]  

1. [File -> New] (size can be anything)  

2. [Process -> Noise -> Salt and Pepper]  

3. [Process -> Filters -> Gaussian Blur] (diameter=2)  

4. [Image -> Adjust -> Threshold..] then “Apply”  



2-2 Basics 

2-2-4 Including ImageJ Macro Commands into your macro 

1. [File -> New] (size can be anything)  

2. [Process -> Noise -> Salt and Pepper]  

3. [Process -> Filters -> Gaussian Blur] (diameter=2)  

4. [Image -> Adjust -> Threshold..] then “Apply”  

macro "GB2_Thr" { 
 newImage("test", "8-bit Black", 300, 300, 1); 
 run("Salt and Pepper"); 
 run("Gaussian Blur...", “sigma=2"); 
 setThreshold(0, 7); 
 run("Convert to Mask"); 

}  



2-2 Basics 2-2-4 Including ImageJ Macro Commands into your macro 

1. [File -> New] 

2. [Process -> Noise -> Salt and Pepper]  

3. [Process -> Filters -> Gaussian Blur] (diameter=2)  

4. [Image -> Adjust -> Threshold..] then “Apply”  

macro "GB2_Thr" { 
 newImage("test", "8-bit Black", 300, 300, 1); 
 run("Salt and Pepper"); 
 run("Gaussian Blur...", "sigma=2"); 
 setThreshold(0, 7); 
 run("Convert to Mask"); 

}  



2-2 Basics 2-2-4 Including ImageJ Macro Commands into your macro 

1. [File -> New] 

2. [Process -> Noise -> Salt and Pepper]  

3. [Process -> Filters -> Gaussian Blur] (diameter=2)  

4. [Image -> Adjust -> Threshold..] then “Apply”  

macro "GB2_Thr" { 
 newImage("test", "8-bit Black", 300, 300, 1); 
 run("Salt and Pepper"); 
 run("Gaussian Blur...", "sigma=2"); 
 setThreshold(0, 7); 
 run("Convert to Mask"); 

}  

newImage(title, type, width, height, depth) 

Opens a new image or stack using the name title. The 
string type should contain"8-bit", "16-bit", "32-bit" or 
"RGB". In addition, it can contain "white", "black" or 
"ramp" (the default is "white"). As an example, use "16-bit 
ramp" to create a 16-bit image containing a grayscale 
ramp. Width and height specify the width and height of 
the image in pixels. Depth specifies the number of stack 
slices.   

From “Build-in Macro Functions” 
ImageJ macro reference:  

 [Help > Macro functions] 



2-2 Basics 2-2-4 Including ImageJ Macro Commands into your macro 

1. [File -> New] 

2. [Process -> Noise -> Salt and Pepper]  

3. [Process -> Filters -> Gaussian Blur] (diameter=2)  

4. [Image -> Adjust -> Threshold..] then “Apply”  

macro "GB2_Thr" { 
 newImage("test", "8-bit Black", 300, 300, 1); 
 run("Salt and Pepper"); 
 run("Gaussian Blur...", "sigma=2"); 
 setThreshold(0, 7); 
 run("Convert to Mask"); 

}  

run("command"[, "options"]) 
Executes an ImageJ menu command. The optional second 
argument contains values that are automatically entered into 
dialog boxes (must be GenericDialog or OpenDialog). Use the 
Command Recorder (Plugins>Macros>Record) to generate run
() function calls. Use string concatentation to pass a variable as 
an argument. With ImageJ 1.43 and later, variables can be 
passed without using string concatenation by adding "&" to the 
variable name.  

From “Build-in Macro Functions” 



2-2 Basics 

2-2-5 Batch Processing using “batch macro” function 

[Process -> Batch -> Macro] 

Copy & paste codes.  

… doing the same processing for all files in a folder. 



2-2 Basics 2-2-4 Including ImageJ Macro Commands into your macro 

macro "GB2_Thr" { 
 newImage("test", "8-bit Black", 300, 300, 1); 
 run("Salt and Pepper"); 
 run("Gaussian Blur...", "sigma=2"); 
 setThreshold(0, 7); 
 run("Convert to Mask"); 

}  

Let’s modify: more flexibility with image size.  

macro "GB2_Thr" { 
 width = 500; 
 newImage("test", "8-bit Black", width, 300, 1); 
 run("Salt and Pepper"); 
 run("Gaussian Blur...", "sigma=2"); 
 setThreshold(0, 7); 
 run("Convert to Mask"); 

}  

We call this a “variable” 

Please run and test! 



2-2 Basics 2-2-4 Including ImageJ Macro Commands into your macro 

Let’s modify: more flexibility with image title.  

macro "GB2_Thr" { 
 width = 500; 
 newImage("test", "8-bit Black", width, 300, 1); 
 run("Salt and Pepper"); 
 run("Gaussian Blur...", "sigma=2"); 
 setThreshold(0, 7); 
 run("Convert to Mask"); 

}  

macro "GB2_Thr" { 
 width = 500; 
 title = "noise image“; 
 newImage(title, "8-bit Black", width, 300, 1); 
 run("Salt and Pepper"); 
 run("Gaussian Blur...", "sigma=2"); 
 setThreshold(0, 7); 
 run("Convert to Mask"); 

}  
We call this a “string” 

Please run and test! 



2-2 Basics 2-2-4 Including ImageJ Macro Commands into your macro 

Let’s modify more!: asking user to input 
macro "GB2_Thr" { 

 width = 500; 
 title = "noise image“; 
 newImage(title, "8-bit Black", width, 300, 1); 
 run("Salt and Pepper"); 
 run("Gaussian Blur...", "sigma=2"); 
 setThreshold(0, 7); 
 run("Convert to Mask"); 

}  

macro "GB2_Thr" { 
 width = getNumber("Width?", 300); 
 title = "noise image“; 
 newImage(title, "8-bit Black", width, 300, 1); 
 run("Salt and Pepper"); 
 run("Gaussian Blur...", "sigma=2"); 
 setThreshold(0, 7); 
 run("Convert to Mask"); 

}  

Please run and test! 



2-2 Basics 2-2-4 Including ImageJ Macro Commands into your macro 

Let’s modify more!: asking user to input 

macro "GB2_Thr" { 
 width = getNumber("Width?", 300); 
 title = "noise image“; 
 newImage(title, "8-bit Black", width, 300, 1); 
 run("Salt and Pepper"); 
 run("Gaussian Blur...", "sigma=2"); 
 setThreshold(0, 7); 
 run("Convert to Mask"); 

}  
Please run and test! 

macro "GB2_Thr" { 
 width = getNumber("Width?", 300); 
 title = getString("Window Title?", "test"); 
 newImage(title, "8-bit Black", width, 300, 1); 
 run("Salt and Pepper"); 
 run("Gaussian Blur...", "sigma=2"); 
 setThreshold(0, 7); 
 run("Convert to Mask"); 

}  



newImage(title, type, width, height, depth) 

Opens a new image or stack using the name title. The 
string type should contain"8-bit", "16-bit", "32-bit" or 
"RGB". In addition, it can contain "white", "black" or 
"ramp" (the default is "white"). As an example, use "16-bit 
ramp" to create a 16-bit image containing a grayscale 
ramp. Width and height specify the width and height of 
the image in pixels. Depth specifies the number of stack 
slices.   

From “Build-in Macro Functions” 

newImage("test", "8-bit Black", 300, 300, 1); 

ImageJ macro reference:  
 [Help > Macro functions] 



2-3 Condition and Loops 

Loop Condition Punk 



2-2 Basics Adding a loop: an example using erosion.  

1. Run the macro… 2. … to create an image 

3. Use the macro recorder to record the following command: 

[Process -> Binary -> Erode] 



macro "GB2_Thr" { 
 width = getNumber("Width?", 300); 
 title = getString("Window Title?", "test"); 
 newImage(title, "8-bit Black", width, 300, 1); 
 run("Salt and Pepper"); 
 run("Gaussian Blur...", "sigma=2"); 
 setThreshold(0, 7); 
 run("Convert to Mask"); 
 run("Erode"); 

}  

4. Append the command run("Erode"); to the current macro.  

macro "GB2_Thr" { 
 width = getNumber("Width?", 300); 
 title = getString("Window Title?", "test"); 
 newImage(title, "8-bit Black", width, 300, 1); 
 run("Salt and Pepper"); 
 run("Gaussian Blur...", "sigma=2"); 
 setThreshold(0, 7); 
 run("Convert to Mask"); 
 for (i = 0; i < 5; i+=1){ 
  run("Erode"); 
 } 

}  

4. Add Looping.  



2-3 Condition and Loops 2-3-1 Loop by “for” 

macro "loop1" { 
 txt = “whatever”; 
 for( i =0 ; i <5 ; i += 1 ) { 
  print(i + “: ” + txt); 
 } 

}  

line 3 for(i=0; i<5; i+=1) sets the looping condition.  

initialize counter 

Condition for exiting the loop 

Increment per loop 

i++ 

*** braces are again to define the 
boundary of “for” looping 

Make a new tab and test it by yourself!! 



2-3 Condition and Loops 

2-3-1 Loop: for-statement 

Exercise 2-3-1-1:  

(1) Change the first parameter in for(i=0;i<5;i+=1) so that 
the macro prints out only 1 line.  

(2) Change the second parameter in for(i=0;i<5;i+=1) so 
that the macro prints out 10 lines.  

(3) Change the third parameter in for(i=0;i<5;i+=1) so that 
the macro prints out 10 lines.  

 i=4 

 i<10 

 i+=0.5 

macro "loop1" { 
 txt = “whatever”; 
 for( i =0 ; i <5 ; i += 1 ) { 
  print(i + “: ” + txt); 
 } 

}  



2-2 Basics using if – else  

macro "GB2_Thr" { 
 width = getNumber("Width?", 300); 
 title = getString("Window Title?", "test"); 
 newImage(title, "8-bit Black", width, 300, 1); 
 run("Salt and Pepper"); 
 run("Gaussian Blur...", "sigma=2"); 
 setThreshold(0, 7); 
 run("Convert to Mask"); 
 for (i = 0; i < 3; i+=1){ 
  run("Erode"); 
 } 

}  

We use this synthetic image to do the following tutorial. 
So make a new tab!  



write these two lines and run it.  

this will print a number in the  
log window… 

… we now further extend this… 



rewrite it using variables. Results should be the same.   

… we now further extend this… 



Now, enclose the code within loop. 
Then replace the value of x from 10 to i  

running this script outputs 50 
numbers. These are the pixel 
values from (0, 10) to (49, 10) 

… we now further extend this… 



We count the number of pixels those with intensity 255.  
-  first line initializing a variable “c255”.  
- three lines for “if” the pixel vale is 255.    
- after looping, prints out the counted number. 



c255 = 0; 
for (j = 0; j < getHeight(); j+=1){ 

 for (i = 0; i < getWidth(); i+=1){ 
  val = getPixel(i, j); 
  if (val == 0){ 
   c255 += 1; 
  } 
 } 

} 
print("255 counts:", c255); 

We could count the number of pixels with value 255 scanning the full range.  



2-3-4 Conditions: if-else-statement 

2-3 Condition and Loops 

Code 12 
1: macro "Condition_if_else 1"{ 
2:  a = getNumber("Input a number", 5); 
3:  if (a == 5) { 
4:   print(a + ": The number is 5 "); 
5:  }  
6: }    

Code 12.5 
1: macro "Condition_if_else 2"{ 
2:  a = getNumber("Input a number", 5); 
3:  if (a == 5) { 
4:   print( a + ": The number is 5 "); 
5:  } else { 
6:   print( a + ": The number is not 5 "); 
7:  } 
8:  print("--------------"); 
9: }    

Exercise: 

Instead of checking if number 
is 5, modify the code, so that  
it evaluates if the given 
number is greater or less 
than 5. 



if there is only one line nested, no {} required! 





2-3-2 Stack Management by for-statement.  

2-3 Condition and Loops 

Code 10 
1: macro "Measure Ave Intensity Stack" { 
2:  frames=nSlices; 
3:  run("Set Measurements...", "  mean redirect=None decimal=3"); 
4:  run("Clear Results"); 
5:  for(i=0; i<frames; i++) { 
6:   currentslice=i+1; 
7:   setSlice(currentslice); 
8:   run("Measure"); 
9:  } 
10: } 



2-3-2 Stack Management by for-statement.  

2-3 Condition and Loops 

Code 10 
1: macro "Measure Ave Intensity Stack" { 
2:  frames=nSlices; 
3:  run("Set Measurements...", "  mean redirect=None decimal=3"); 
4:  run("Clear Results"); 
5:  for(i=0; i<frames; i++) { 
6:   currentslice=i+1; 
7:   setSlice(currentslice); 
8:   run("Measure"); 
9:  } 
10: } 

nSlices 
Returns the number of slices in the current stack. 
Returns 1 if the current image is not a stack.  

setSlice(n) 
Displays the nth slice of the active stack. Does 
nothing if the active image is not a stack.  



2-3-2 Stack Management by for-statement.  

2-3 Condition and Loops 

Code 10 
1: macro "Measure Ave Intensity Stack" { 
2:  frames=nSlices; 
3:  run("Set Measurements...", "  mean redirect=None decimal=3"); 
4:  run("Clear Results"); 
5:  for(i=0; i<frames; i++) { 
6:   currentslice=i+1; 
7:   setSlice(currentslice); 
8:   run("Measure"); 
9:  } 
10: } 

Open an example stack 1703-2(3s-20s).stk. Select FRAPped 
region by polygon ROI tool. Execute the macro. Results will be 
printed in the Results window. 



2-3-2 Stack Management by for-statement.  

2-3 Condition and Loops 

Code 10 
1: macro "Measure Ave Intensity Stack" { 
2:  frames=nSlices; 
3:  run("Set Measurements...", "  mean redirect=None decimal=3"); 
4:  run("Clear Results"); 
5:  for(i=0; i<frames; i++) { 
6:   currentslice=i+1; 
7:   setSlice(currentslice); 
8:   run("Measure"); 
9:  } 
10: } 

Exercise 3-2-1: Modify code 10 to include more 
measurement parameters (whatever you like), and 
test the macro. Check the results.  

Hint: use   + Macro Recorder 



2-3-2 Stack Management by for-statement.  

2-3 Condition and Loops 

Code 10 
1: macro "Measure Ave Intensity Stack" { 
2:  frames=nSlices; 
3:  run("Set Measurements...", "  mean min integrated redirect=None decimal=3"); 
4:  run("Clear Results"); 
5:  for(i=0; i<frames; i++) { 
6:   currentslice=i+1; 
7:   setSlice(currentslice); 
8:   run("Measure"); 
9:  } 
10: } 

Exercise 3-2-1: Modify code 10 to include more measurement parameters 
(whatever you like), and test the macro. Check the results.  



2-2 Basics 



2-2 Basics 

2-2-2 Variables, Strings 

Code 2 
1:  macro "print_out" { 
2:  text = ”Hello World!"; 
3:  print(text); 
4:  text = ”Bye World!"; 
5:  print(text); 
6: } 

String Assignments 
String Variable 

Code 3 
1: macro "print_out" { 
2:  text1 = "Hello"; 
3:  text2 = " World!"; 
4:  text3 = text1 + text2; 
5:  print(text3); 
6:} 

Exercise 2-2-2-1: Add more string variables 
and make a longer sentence. Check your 
macro by running it. 

String concatenation 



2-2 Basics 

2-2-2 Variables, Strings 

Numerical variable Assignments 

Code 4 
1: macro "print_out_calc" { 
2:  a = 1; 
3:  b = 2; 
4:  c = a + b; 
5:  print("\\Clear");    
6:  print(c); 
7:  print(a + "+"+ b + "="+c); 
8:  txt=""+a + "+"+ b + "="+c; 
9:  print(txt); 
10: } 

Numerical variable 

message_text = 256; 

message_text = “256”; 

 Nummerical 

 String function 

txt=a + "+"+ b + "="+c;  

Exercise 2-2-2: Modify the code 4, so 
that the calculation involves subtraction 
(-), multiplication (*) and division (/).   



2-2 Basics 

2-2-3 parameter input by user 

Code 5 
1: macro "input_print_out_calc" { 
2:  a = getNumber("a?", 10); 
3:  b = getNumber("b?", 5); 
4:  c = a*b; 
5:  print("\\Clear"); 
6:  print(c); 
7:} 

Syntax:  getNumber(message string, default number) 
 return value: user input number 

Numerical Function 
Clears Log Window 



2-2 Basics 

2-2-3 parameter input by user 

Syntax:  getString(message string, default string) 
 return value: user input string 

Code 6 
1: macro "input_print_out_str" { 
2:  a = getString("a?", “hello”); 
3:  b = getString("b?", “ world!”); 
4:  c = a+b; 
5:  print("\\Clear"); 
6:  print(c); 
7: } 

String Function 

Exercise 2-3-1: Run the code 6 and input 1 for a and 2 for b. 
What happened? Explain the reason.  



2-3 Conditions and Loops  



2-3-3 Loop: while-statement 

2-3 Condition and Loops 

Code11 
1: macro "while looping1" { 
2:  counter=0; 
3:  while (counter<=90) { 
4:   print(counter); 
5:   counter = counter + 10; 
6:  } 
7: }    

counter += 10; 

counter = counter - 10; counter -= 10; 

counter = counter * 10; counter *= 10; 

counter = counter / 10; counter /= 10; 

counter += 1; counter ++; 

counter -= 1; counter --; 

Exercise 2-3-3-1-1:  
(1) Change code 11 so that it uses 

“+=” sign.   
(2)  (2) Change code 11 so that it uses 

“++” sign, and prints out integers 
from 0 to 9.  



2-3-3 Loop: while-statement 

2-3 Condition and Loops 

Code11 
1: macro "while looping1" { 
2:  counter=0; 
3:  while (counter<=90) { 
4:   print(counter); 
5:   counter += 10; 
6:  } 
7: }    

Code 11.5 
1: macro "while looping2" { 
2:  counter=0; 
3:  do { 
4:   print(counter); 
5:   counter += 10; 
6:  } while (counter<0) 
7: }    

Exercise 2-3-3-1-2: Change the line 3 of code 11 to 
“while (counter <0)” and check the effect. 

<, <=   less than, less than or equal  
>, >=   greater than, greater than or equal  
==, !=   equal, not equal  

Exercise 2-3-3-1-3: Modify code 11 so that the macro 
prints out numbers from 200 to 100, with an 
increment of -10.  



2-3-4 Conditions: if-else-statement 

2-3 Condition and Loops 

Code 12 
1: macro "Condition_if_else 1"{ 
2:  a = getNumber("Input a number", 5); 
3:  if (a == 5) { 
4:   print( a + ": The number is 5 "); 
5:  }  
6: }    

Evaluate the condition of 
numerical variable 
input_num 

Exercise: 
write the code! 
Don’t delete the code, we extend it in the next slide! 



2-3-4 Conditions: if-else-statement : complex conditions 

2-3 Condition and Loops 

Code 12.75 
1: macro "Condition_if_else 3"{ 
2:  a = getNumber("Input a number 1", 5); 
3:  b = getNumber("Input a number 2", 6); 
4:  message0 = ""+ a + ","+ b;   //use this string four times 
5:  if ( (a == 5) && ( b == 6) ) { 
6:   print(message0+ ": The parameter1 is 5 and the parameter2 is 6"); 
7:  } else { 
8:   if (a != 5) && (b != 6) { 
9:    print(message0 + ": The parameter1 is not 5 and the parameter2 is not 6"); 
10:   } else { 
11:    if (b == 6) { 
12:     print(message0 + ": The parameter1 is NOT 5 but the parameter2 is 6"); 
13:    } else { 
14:     print(message0 + ": The parameter1 is 5 but the parameter2 is NOT 6"); 
15:    } 
16: }  

Line 8: if ( (a != 5) && (b != 6) ) 

Line 5: if ( (a == 5) && (b == 6) ) 

&&   boolean AND 
||   boolean OR 



Exercise if there is only one line nested, no {} required! 



2-3-4 Conditions: if-else-statement : Application 

(see the actual macro working first) 



2-3-4 Conditions: if-else-statement : Application 

Code 13 
1: macro "Generate Dot Movement back and forth" { 
2: // **** initial values **** 
3:  sizenum=10;  //dot size  
4:  int=255;   //dot intensity 
5:  frames=50;   //frames in stack 
6:  w=200;   //width of frame  
7:  h=50;   //height of frame  
8:  x_position = 0;  // x position: changes with speed defined later 
9:  y_position= (h/2)-(sizenum/2);  //y positon of the oval top-left corner: constant 
10: //**** set colors ***** 
11:  setForegroundColor(int, int, int); 
12:  setBackgroundColor(0, 0, 0); 
13: //**** ask speed ***** 
14:  speed=getNumber("Speed [pix/frame]?",10) 
15: //**** prepare stack **** 
16:  stackname="dotanimation"+speed;   
17:  newImage(stackname, "8-bit Black", w, h, frames); 
18: //**** drawing oval in the stack **** 
19:  for(i=0; i<frames; i++) { 
20:   setSlice(i+1); 
21:   makeOval(x_position, y_position, sizenum, sizenum); 
22:   run("Fill", "slice"); 
23:   if ((x_position > (w-sizenum)) || (x_position < 0) ) {  
24:    speed*=-1; 
25:   } 
26:   x_position += speed; 
27:  } 
28: } 

Sets initial values 

Set Drawing / Background Color 

User inputs the speed 

Prepare Stack to be drawn 

Drawing Dot in 
each frame (for 
loop) 

“If” statement  switching direction 



2-3-4 Conditions: if-else-statement : Application 

Code 13 
1: macro "Generate Dot Movement back and forth" { 
2: // **** initial values **** 
3:  sizenum=10;  //dot size  
4:  int=255;   //dot intensity 
5:  frames=50;   //frames in stack 
6:  w=200;   //width of frame  
7:  h=50;   //height of frame  
8:  x_position = 0;  // x position: changes with speed defined later 
9:  y_position= (h/2)-(sizenum/2);  //y positon of the oval top-left corner: constant 
10: //**** set colors ***** 
11:  setForegroundColor(int, int, int); 
12:  setBackgroundColor(0, 0, 0); 
13: //**** ask speed ***** 
14:  speed=getNumber("Speed [pix/frame]?",10) 
15: //**** prepare stack **** 
16:  stackname="dotanimation"+speed;   
17:  newImage(stackname, "8-bit Black", w, h, frames); 
18: //**** drawing oval in the stack **** 
19:  for(i=0; i<frames; i++) { 
20:   setSlice(i+1); 
21:   makeOval(x_position, y_position, sizenum, sizenum); 
22:   run("Fill", "slice"); 
23:   x_position += speed; 
24:   if ((x_position > (w-sizenum)) || (x_position < 0) ) {  
25:    speed*=-1; 
26:   } 
27:  } 
28: } 

(x_position, y_position) 

sizenum 

sizenum
 

makeOval(x, y, width, height) 
Creates an elliptical selection, where (x,y) 
define the upper left corner of the 
bounding rectangle of the ellipse.  



2-3-4 Conditions: if-else-statement : Application 

Code 13 (part) 
23:   x_position += speed; 
24:   if ((x_position > (w-sizenum)) || (x_position < 0) ) {  
25:    speed*=-1; 
26:   } 

x_position > (w-sizenum) x_position < 0 

(0, 0) 

sizenum 

(0, y_position) 

x 

y 

(w, 0) 

sizenum 

(w-sizenum, y_position) 



2-3-4 Conditions: if-else-statement : Application 

Code 13 
1: macro "Generate Dot Movement back and forth" { 
2: // **** initial values **** 
3:  sizenum=10;  //dot size  
4:  int=255;   //dot intensity 
5:  frames=50;   //frames in stack 
6:  w=200;   //width of frame  
7:  h=50;   //height of frame  
8:  x_position = 0;  // x position: changes with speed defined later 
9:  y_position= (h/2)-(sizenum/2);  //y positon of the oval top-left corner: constant 
10: //**** set colors ***** 
11:  setForegroundColor(int, int, int); 
12:  setBackgroundColor(0, 0, 0); 
13: //**** ask speed ***** 
14:  speed=getNumber("Speed [pix/frame]?",10) 
15: //**** prepare stack **** 
16:  stackname="dotanimation"+speed;   
17:  newImage(stackname, "8-bit Black", w, h, frames); 
18: //**** drawing oval in the stack **** 
19:  for(i=0; i<frames; i++) { 
20:   setSlice(i+1); 
21:   makeOval(x_position, y_position, sizenum, sizenum); 
22:   run("Fill", "slice"); 
23:   x_position += speed; 
24:   if ((x_position > (w-sizenum)) || (x_position < 0) ) {  
25:    speed*=-1; 
26:   } 
27:  } 
28: } 

Exercise 3-4-3-1:   

Modify code 13 that the dot moves 
up and down vertically. Change the 
stack width and height also.  
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